Potentially bug with updating a feed

As I am not sure I think this forum is the perfect place to confirm it or not. :smile:

I have a feed which has a new episode but AntennaPod 2.0.0-RC4 won’t update to show there is.
Using feed directly in Firefox / chrome on phone display new episode. Trying adding back feed do not work either. I’m thinking they might be a bug with retrieving feed? Can someone confirm it’s not specific to me? (There should an episode 107 released yesterday)

Feed podcast is : https://www.afterhate.fr/feed/podcast

out of topic : it’s great to have set up dedicated forums for AntennaPod.

1 Like

The episode is shown on my device. This sounds like a caching issue. Version 2.0.0 caches feed responses to make updating the feed list faster. That server supports ETAG, so it should be updated as soon as the content changes. I guess I need to have a look at caching again…

If you want, you can use Android’s settings app to clear the cache (not data!) of AntennaPod.

2 Likes

Before clearing cache I tried to update and it worked. But it’s nice to have a workaround. :slightly_smiling_face:
I would say it took from 0.5 day to 1 day to update.

1 Like

I find this to be something I have to use occasionally. I’m a beta tester for 8 or 9 apps and it appears to be more commonly needed when there are certain types of changes made in app development. It also helps if you notice the app slowing down much more than it done previously.

Starting with 2.0.0-RC6, AntennaPod no longer caches feeds and always does a fresh web request (just like in 1.8.1). Looks like many servers do not behave properly and we have to ignore their caching instructions at the cost of slower refresh and more network bandwidth…

That makes sense. I can accept that as a downside in order to have an accurate refresh.