Unable to delete or download/update podcasts

App version: 2.4.0 from GooglePlay

Android version: 8.1.0

Device model: Moto G5s Plus

Expected behaviour:
Manual download or deletion of podcasts

Current behaviour:
When I try to delete files, I get an error message “unable to delete. Restart may help.”(paraphrasing).

When I try to download files, I get “I/O error” or “E/A error” or “invalid type”.

First occurred: about 3 days ago.

Steps to reproduce:
I tried

  1. Restart
  2. Deleting cache
  3. Reinstall (using database export and import)
  4. Deleting cache partition
    I also made sure that antenna pod has reading/writing rights.

Environment: No auto download or deletion or any special settings I am aware of, especially since I reinstalled and only changed some buttons.
Thank you in advance for any help!

What’s your selected AntennaPod data folder? Sounds like it cannot access the folder.

It is on an sd-card.
/storage/829A-1AF5/Android/data/de.danoeh.antennapod

Did you recently change your sd card? Try selecting the internal storage and see if that makes the errors go away

I haven’t changed the card. I changed the folder from internal at least several weeks ago, but was still able to download files after that.
Changing the folder now does not solve the problem.

@bytehamster: You were on the right track - the SD card was the problem.
I noticed that I actually was able to download new files after switching the folder to internal.
However, I urgently had to free up space after just one download, so I tried transfering some unrelated files from internal to external memory. That failed for some reason.

As it turns out, the SD card was damaged, which automatically activates write protection apparently.
After switching to another card everything works as it should. Thank you for your support!

1 Like