404 trying to connect to self-hosted gpodder.net

App version: 3.1.2 (8d4270ab8) (from F-Droid)

Android version: GrapheneOS 14

Device model: Pixel 7

Expected behaviour:
I’m trying to sync AntennaPod to Podfetch via Podfetch’s GPodder API (GPodder API · SamTV12345/PodFetch Wiki · GitHub). I expect AntennaPod to connect to Podfetch (or to GPodder via Podfetch) and allow me to either continue configuration or begin syncrhonization.

Current behaviour:
“Unable to connect to GPoddner. net (code 404: Not Found)”

First occurred:
N/A (just started trying to sync today)

Steps to reproduce:

  1. AntennaPod → Settings → Syncrhonization → click “Choose synchronization provider”
  2. click “Gpodder. net”
  3. enter URL to my podfetch instance
  4. enter login and password of a Podfetch user
  5. click “Log in”

I also tried entering the URL and login credentials for my GPodder instance, but got the same result.

I know this looks like a bug report, but most likely I’m just doing something wrong and would appreciate some assistance.

Have you tried asking the podfetch developers? I’m not sure people here can help to debug server setup stuff. I don’t know anything about running podfetch.

Thanks for the reply, @ByteHamster. I haven’t asked Podfetch or GPodder people yet. I was thinking that since AntennaPod is failing to connect to a server, it might be an Antennapod issue (or a config in AntennaPod I’ve got wrong). I’ll ask elsewhere as well.

So maybe to generalize my question here: if AntennaPod gets a 404 trying to connect to a GPodder instance that I know is up and I can manually connect to, what configs in AntennaPod might I change? Has anyone encountered this in AntennaPod?

The only thing you can really enter is the address, so I guess the address must be wrong. I don’t know, maybe you need to specify a subfolder or something.

Gpodder has never been reliable, if your thing is just a front end for it, I’d keep searching. I sync mine with my Nextcloud instance.

Hey Mike, did you solve your issue? Like others said, this might be a podfetch problem, but I bet there’s an interest from more people to get this up and running. If you’re still struggling with this, write about your setup (rev.proxy, OS, network setup etc) and I’ll see if I can get it up and running.

To the antennapod team, it would be handy if the connection error at the sync widget would contain more information to make it easier to troubleshoot.

Thanks for the offer to help, @Krash, but I wasn’t able to get it to work and every response I saw was “it doesn’t work,” so I gave up. I’m using Audiobookshelf now, which does what I want via its own app (so I’m no longer using Antennapod).

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.