AntennaPod will not play since upgrade

App version: x.y.z (state whether from Google Play/F-Droid/Custom built APK)
3.1(?) From the app store

Android version: 5.x (Please mention if you are using a custom rom!)

Device model:
Pixel 6

Expected behaviour:
Opens and plays

Current behaviour:
Opens but will not play

First occurred: (e.g. about x days/weeks ago)
On upgrade to current version

Steps to reproduce:

  1. This
  2. Then that
  3. Then this
  4. Etc.

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)

I can see all episodes and select them but not a single one will play. The app seems to try but then just stops - app doesn’t seem to crash and it doesn’t close.
Tried to download then pkay, didn’t work either.

Any suggestions mosr welcome as i love the app!

For the avoidance of doubt, everything is vanilla and OOB.
Everything worked normally before the upgrade - the upgrade appears to have found a bug which is preventing download/playing of podcasts.

The current version is from the play store as fDroid was/is an old version.

Looks like 3.1.0 is the current version on the Play Store. I’m enrolled in the beta so I actually have 3.1.1 but I don’t recall having any issues on 3.1.0 either on my Pixel 7a.

Have you tried uninstalling and reinstalling the app? Sounds like maybe something in the database got corrupted. The other option if you don’t want to lose your play history, etc. would be to contact the Dev team and provide your database and have them take a look.

Not being able to play is not something that could be caused by a database corruption. I would rather try different networks. Also make sure to disable everything that could mess with the network connection, like VPNs, ad blockers, secureDNS, Blockada, PiHole, etc.

Thank for the thought, that was the first thing I did (uninstall and reinstall), but that hasn’t made any difference.
I also tried going back to the old version but it doesn’t recognise the database I exported :roll_eyes:

Yep do have a VPN and stopped it to test but that made no difference.
Definitely not a connection issue as i can play the radio…

Ah, good to know that playback issues shouldn’t be database related.

In the past, Blockada has blocked some podcast-specific pages but not normal websites. So being able to play the radio might not rule out network problems.

Another idea would be to long-press the episode, share the media address, and try if it works in a web browser. Similarly, you could share the media file (if downloaded) and try to play it.

I am having the same issue. On a Pixel 5a running CalyxOS

TBH it is a definite bug and connecte to downloading/playing of the podcasts as I’m unable to download on any connection.
I’ve now moved to the dark side (Google) as Im out of time to continue troubleshooting.

Sorry guys but I’m out…

Sad to hear. So you didn’t get the time to try these?

Ive already tried those and nothing plays via the app - they’re all fine on Google so there’s no doubt in my mind.
Sorry but I can’t make the time to keep testing different routes to get something working when i know how it should work and it doesn’t.
Must admit I’ve little patience for tech now, which doesn’t help - too many years at the coal face dealing with tech that doesn’t work!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.