Apparent Buzzsprout Issue

App version: 5.1.3 from google play

Android version: 9

Device model: SM-J737U

Expected behaviour: Search for a podcast, that podcast appears and can be listened/subscribed to.

Current behaviour: I can successfully search for a podcast in the general or iTunes search bars on the “Add Podcast” page, but clicking it brings up an error, as does using an RSS feed link. The error reads “IO Error (Failed to connect to

First occurred: Yesterday

Steps to reproduce:
Search Version

  1. Go to “Add Podcast”
  2. Tap the “search podcasts” box
    2.a. OR you can tap the “search iTunes” link/button
  3. Search for the podcast (the following were my test searches)
    3.a. “you’re wrong about”
    3.b. “maintenance phase”
    3.c. “queer writers of crime”
  4. Tap the first podcast in the list
  5. Error message pops up

RSS Version

  1. Go to “Add Podcast”
  2. Tap the “add podcast by RSS address” link/button
  3. Enter the appropriate RSS link which is “” where the #s are the podcast’s id, I used the following ids corresponding to the above version’s shows.
    3.a. 1112270
    3.b. 1411126
    3.c. 550930
  4. Error message pops up

Environment: Nothing unusual on my device. I didn’t/don’t know what level this problem is on (aka with AP or buzzsprout or the podcast itself), but I have found and tried 3 podcasts hosted on buzzsprout with this same error message.

Disable your VPN/ad blocker

1 Like