Automatic Download Does Not Work

App version: 3.1.2 downloaded from Google Play

Android version: Android 12

Device model: Nokia 5.3

Expected behaviour: when the podcasts are refreshed, the most recent episode should be automatically downloaded when “automatic download” is turned on.
When adding a new podcast, if the checkbox “Include in auto downloads” is turned on, the latest episode should start downloading.

Current behaviour: episodes aren’t automatically downloaded in both the cases

First occurred: not sure when this strange problem started happening

Steps to reproduce:

  1. Go to the -menu or subscriptions screen and tap on “add podcast”
  2. Look for XYZ podcast
  3. Tap on any podcast and make sure the the checkbox “Include in auto downloads” is checked, and tap “subscribe”
  4. Check if the most recent episode of that podcast is being downloaded or not

Environment: Auto Download is turned on with Episode Cache set to “unlimited”, and I’m connected to an unmetered Wi-Fi connection.

I am new to Antennapod, having same problem. Pixel 3a phone. Looking for a new app if I can’t solve this.

Also having this issue. Started a couple of weeks ago.

Have tried increasing episode limit to unlimited, refreshing etc.

Subscriptions are included in auto downloads

Can’t seem to get the app to download episodes apart from manually on each one.

Pixel 5. Android 12

Hi @VoidCrater, @rhllnm, @Edenspresence,

Thanks for chipping in on our community forum :slight_smile:

Please make sure that

  • The global settings are correct:
    Settings > Downloads >
    • ‘New episodes action’ is set to ‘Add to inbox’
    • ‘Refresh podcasts’ is set to an interval
    • ‘Automatic download’ is enabled
  • The podcast-specific settings are correct:
    Podcast XY > :gear: icon (settings) >
    • ‘Keep updated’ & ‘Include in auto downloads’ are enabled
    • ‘New episodes action’ is set to ‘Global default’ or ‘Add to inbox’

The ‘New episodes action’ was recently added and setting it to ‘None’ has a bit of unintended effects on auto-download. We’re currently discussing how to improve this.

Hope that helps!

Hi @keunes

Thanks for the reply.

Those settings are definitely all in place now. I had changed the one about New episode action before so it could be the issue you described.

I will come back here when some new episodes are released and let you know if they are auto downloaded.

I had turned it off since nothing was ever appearing in my inbox anyway. It was always empty. That is weird too isn’t it?

1 Like

It’s always empty because auto-download immediately processes the new episode. And because the episode is processed, we consider it not ‘new’ anymore, thus remove it from the inbox.

That’s something we’re discussing to change now. So the idea is that the episode will stay in the Inbox even if it’s auto-downloaded, until you interact with that episode manually (mark it favourite, start playing, remove from queue, mark played, etc).

Would that make sense to you?

Hello,

Firstly, I can confirm that auto-download now works again. I refreshed manually, saw a new episode enter the inbox, download and then leave.

Podcast management is so personal, I can see how difficult it is for logic on an app to suit everyone!

I can see lots of sense with the inbox, I just don’t think I understood it.

For what it’s worth, I think I have four kinds of podcast:

  1. listen to every episode, every week
  2. decide on a title by title basis (daily news for example)
  3. keep as a subscription but rarely listen to, sometimes just flick through
  4. working through in order (something like serial)

I was auto-downloading 1&2 but I might switch type 2 to not autodownload. They would then appear in my inbox as per it’s intention.

I think the issue in this thread is fixed for me at least.

Thanks for all the hard work. I really like AntennaPod. If anything I have contributed helps then great!

1 Like

I think that’d work yeah.

With pleasure :slight_smile: Don’t hesitate to chip in again if you have any other feedback in future!

Hi, new to the forum and I’m having what appears to be the same issue.

Pixel 6, Android 14, Feb 15 '24 security updates, Jan 1 '24 Google Play system update.

AntennaPod version 3.2.0

Global settings:
Refresh podcasts - Every Hour
New episodes action - Add to inbox
Automatic download - enabled (episode cache 5, episode cleanup 7 days after finishing, download when not charging enabled)

Podcast-specific settings:
Keep updated - enabled
New episodes action - Global default
Include in auto downloads - enabled

All new episodes are showing up in my inbox, but they all have the “download” icon showing next to them. Only episodes available locally are ones that I’ve manually pushed the “download” button. Thanks in advance for any ideas!

I assume you are subscribed to multiple podcasts and this is happening with all podcasts, not just the episodes for one podcast? I ask because your settings mirror my configuration except for episode cache and episode cleanup values and I’ve having no issues.

The last time I had issues with episodes not downloading it ended being isolated to a specific podcast and it was because they were having issues with their RSS feed.

Yes, subscribed to 24 podcasts, all doing the same thing.

I should have noted, settings in the Mobile updates section:

  • Podcast refresh On
  • Episode download On
  • Auto download OFF (maybe this is my issue?)
  • Streaming On
  • Cover images On
  • Synchronization On

My intention with these settings was to allow all functionality on mobile data (I don’t have unlimited data mobile plan) EXCEPT for auto downloading, which I only wanted to occur on Wifi. I wonder, though, if it’s not working because the episodes refresh on mobile data but then can’t auto download.

I’ll try turning off all mobile updates and see if it works correctly just on Wifi.

Yeah, you might be on to something as that’s the only other difference I’m seeing between your settings and mine.

I re-installed AntennaPod and used only the recommended settings from this thread and auto-download started working. It then “stopped” working, and I realized that my problem all along was likely a misunderstanding of how the Episode Cache setting works. When I took the time to actually read the description of the setting, it clearly states that automatic downloads will be suspended once the threshold is reached, which is likely what happened with my original instance as well (when I first installed I manually downloaded several episodes and likely hit the cache limit before it had a chance to auto download anything). So apparently no problem here other than my not reading the documentation.

2 Likes

Glad to hear you figured it out!

Glad to see such an active community here! Just switched from another app to Antennapod, and I quite like what I see.
The Inbox is a new thing for me, and I don’t quite see the added value for it. There is already the Episodes tab, which could do the same things the Inbox is meant for. New episodes could be highlighted, and one could decide per episode what to do with it, or just tap some kind of “All seen” which would de-highlight all episodes. There could be options to automatically mark a new episode as seen, when auto download is enabled. I think the Inbox may add an extra level of (unnecessary) complexity.
Just my 2 cents, I’m very exited to see how this app will develop in the future.

I came here because auto downloading was not working, and the marked solution worked for me :+1:

When auto download is enabled the new episodes are automatically removed from the InBox.

If automatic download is enabled the InBox will be empty and you’ll have no need of it. In that case I’d recommend removing it from your home page. Voila - less complexity. :white_check_mark:

This is also my preference and if I understand it correctly, this means that if I refresh episodes over mobile, they will not get autodownloaded even later when I get to a wifi connection, right? I thought this was the case but then I stumbled on this thread and realized my inbox setting was wrong so autodownloads were not working at all.