Bluetooth resumes no matter what I do to stop it

App version: x.y.z (state whether from Google Play/F-Droid/Custom built APK)

version 2.5.1. Latest from FDroid. I’ve only ever installed it from fdroid. I don’t use any other app store. The phone is completely degoogled.

Android version: 5.x (Please mention if you are using a custom rom!)

11

Lineageos build 18.1 from 7th October 2021

Device model:

Pixel 4A

Expected behaviour:

Bluetooth should not restart everytime I start my vehicle as I have disabled that feature in the app settings.

Current behaviour:

Bluetooth playback starts no matter what I set in the app settings. I cannot find a way to stop it.

First occurred: (e.g. about x days/weeks ago)

Since install about 3 days ago.

Steps to reproduce:

Turn off the setting that enables automatic resuming when bluetooth is reconnected, but it resumes anyway.

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)

Auto download is off.
I use it connected to my car radio - volkswagen.
No headphones. Never tried the app with headphones.

No I didn’t try any of the other media player settings in the app as If I remember correctly it says they are obsolete??

===============================

I use a de-googled phone (lineageos). I get my apps from fdroid only and out of all the podcast apps on fdroid antennapod is the best to use, but for the moment I have had to uninstall it for one reason.

I have it set to not resume when bluetooth is reconnected in my vehicle, but even with this setting, and even when I have shut the app down and remove it from the recent apps screen, whenever I start the engine the app starts up and starts playing whatever I was listening to last. I then have to open the app up so I can stop the playback.

Is there a bug, or something I am missing?

My guess would be that your car sends a “play” button press to the phone when you start it

I wondered about that so I searched in the car radio settings to see if there was anything I could turn off, but there wasn’t.

I’ve tried 2 other podcast apps and they resume if I’ve left the app running in the background (i.e - visible in the recent apps list), but if I remove them from recent apps they do not resume, whereas antennapod does.

I still have these apps installed and use one of them for now, but I’m posting here as antennapod is better so I’d like to use it.

I have the same problem. It is really bad especially when I use my remote start and it connects to my phone while I’m still in my house and I miss a huge chunk of my podcast.

I have a feeling that the car IS sending a play command. Car software is so horrendous and we can’t expect them to fix this or even realize how bad their UX is, is there any fix that can be done on Antennapod’s end?