Cannot download some Podcasts for 24h+

Good evening,
I’m running v2.1.3 from the Play Store on a Nexus 6p running Lineage 15.1 (android 8.1, kernel 3.10.73)

Starting yesterday I’ve been unable to download two podcasts, The Daily from the NYT and Pod Save America from Crooked Media.

Other downloads, like On the Media (from WNYC) and Stay Tuned with Preet (from Cafe) still were able to.

When I look at the download log the error is “IO Error: Trust anchor for certification path not found.”

I tried yesterday and today wondering if there was an SSL cert they needed to update but I haven’t gotten different behavior. Is there anything I can look into further to help track this down? I’m not a developer but will troubleshoot if I can.


Same issue here as well. Antennapod v2.1.2 on a moto z2 running android 10/lineage OS. Some podcasts will not download but they still end up in my queue, where they remain unresponsive/unable to download or play. Noticed the issue this morning.

Thanks team for all your hard work on this awesome app!

Do you use an ad blocker/VPN/etc that messes with your network connection?

I have Adaway and a VPN, yeah. But prior to yesterday morning they didn’t seem to interfere. I’ve also been able to recreate the issue with the VPN turned off. And fwiw I haven’t updated the hosts file in Adaway in at least a week, but I’ll try disabling that in a bit and see if it’s relevant.

I also use AdAway, which recently implemented auto updates.
I disabled AdAway on my phone, and was able to download the podcasts.
Thank you!
(I also have a pihole on my network which doesn’t seem to interfere)
I’ll dig around a bit to see if I can rectify it in AdAway.

Same here! I just toggled Adaway off and everything worked as expected. Toggled it back on and everything still works as well. Seems that was the source.

Cheers I’m glad that was so easy. Strange that I’ve been using both Antennapod and Adaway in tandem for a long time and they seem to play well together.

Brief follow-up:
I have 3 sources in AdAway - official, Pete Lowe, and
I disabled them individually, and it was the AdAway official list that created the problem.
I guess I’ll open a thread with them next!

Thanks again for the help and I love this app!


Running adblock on home router and had to add “” to whitelist - so far, so good. Culprit is adaway list. Background: couple of days ago problems started with eps of “Stuff You Should Know”, “Stuff You Missed in History Class”, and others I don’t remember.

Yeah, I whitelisted three domains in AdAway (dts.podtrac .com, chtbl .com and simplecastaudio .com) but still was having trouble with The Daily. I then figured out that pihole also blocks so had to white list it there, too.