Cannot import OPML file - error about external storage

App version: 3.2.0 (Google Play
Android version: 13.
Device model:OPPO Find X3 Lite 5G
Expected behaviour: Load in OPML file from device
Current behaviour: AntennaPod then always shows a message ‘Access to external storage is required to read the OPML file’ - I don’t have any external storage on my phone, it is all internal storage and I can’t find any permissions to allow this access.
First occurred: 3 days ago on first download
Steps to reproduce:

  1. Go to settings
  2. Click import/export
  3. Click OPML import
  4. Choose OPML file from downloads folder
  5. Error message comes up
    Environment: Default, this was the first thing I tried to do.

Android calls everything you can see “external storage”, just the internal system files you cannot see are “internal storage”.

Apparently your phone manufacturer added weird changes to the file picker app. If there is another file picker app, try that one instead. If not, you have to wait for a possible fix that I just added, which will probably be released in AntennaPod 3.3.0

Thanks ByteHamster. I’ve tried moving the file around where I can see to no avail :sob:

I’ll just have to wait for the next version to see if that fixes it.

@ilathwel If you long hold the AntennaPod icon, go to App Info, can you grant permissions?

No. The only app permissions I have is for notifications :sob:

My other trick is to install Google Drive app, upload your
OPML there and import it from Google Drive


You are an absolute genius!!

That worked, of course who knows why I didn’t work that out.

Many thanks

1 Like

Glad it worked for you

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.