Cannot stream nor download from podcast

I’m trying to add a new podcast, yet it wouldn’t stream nor download.
All I get is the following message:

java.util.concurrent.ExecutionException: javax.net.ssl.SSLHandshakeException: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

AntennaPod asks for network issues (tried in different WiFis and via mobile data), VNP (nope) or auth-site (nope). Podcast is hosted on blubrry so it shouldn’t actually be a problem?!

Using AntennaPod-Version 3.4.0 (5f5d744e7) on Android 9.

Hrm. Interesting SSL error.

If you put the podcast URL into a browser, do you see the RSS feed text?

By chance, are you using an Android version from some other place than Google?
Have you done anything related to self-signed certificates or removing other certificates on the device?

Thanks for the reply!

What exactly do you mean by “the podcast URL”? If I hit the little globe icon on the individual episode’s site, the episode’s website comes up in my browser.

Nope.

Not that I know of. I might be a bit restrictive with access rights on the device, but everything I did was through standard setup apps and/or the Google Play Store.

You have to copy RSS URL from your podcast, paste it in your browser as an address. Your browser should be able to show the feeds. (In XML forms probably, but extensions exists to format it. Not relevant here)
If your browser fail to display it then there is a problem with the feed. Or the feed (RSS) address is not correct.

I’ve got the same problem - the podcast I listen to is http://372pages.com/ - it worked about 2 weeks ago, now I can’t download any episodes (the feed itself works fine). Also, this isn’t related to the recent AntennaPod update, I think maybe it broke around 14th May, I see there was a cert change on the blubrry server then.

I tried downloading the mp3 from the feed in Chrome on Android, that works OK too, it’s only in AntennaPod that it fails mysteriously.

I’m using Android 9, AntennaPod 3.4.0 from the Play Store. The previous version of AnennaPod has the same issue, which would have been 3.3.2.

The download log says:

Unable to establish a secure connection. This can mean that another app on your device (like a VPN or an ad blocker) blocked the download, or that something is wrong with the server certificates. 

Technical reason: 
java.security.cert.CertPathValidatorException: Trust anchor for certification path not found. 

File URL: https://media.blubrry.com/372pages/372pages.com/episodes/372pages_143.mp3

I’ve been able to test it using a new phone, and the downloads work correctly. I guess Android 9 is too old and doesn’t have the root certificate that the MP3 host uses :frowning:

Feed looks okay. But that was to be expected as all the episodes display correctly.

How unfortunate. Anything one can do about that (easily)?

My “solution” for this is going to be use NewPipe for this one podcast, as it is on Youtube too, and longer term buy a new phone. There’s a slim chance that Google adds the root certificate to their gubbins in the Play Services, I think they can do that, which may fix it, but otherwise as an end user there’s nothing you (or I) can do.

Since the RSS seems to be able to be downloaded and parsed correctly – is there any possibility to manually download the files and place them within AntennaPod’s download directory? Or would I need to modify a database as well? :thinking:

Not like that no, I tried putting the files in the download directory and they are not recognised. It shows as not downloaded. I did download the file manually and import the directory though, that worked. So I have the RSS feed and a separate podcast that’s the local folder.

I have same error shown in the download log clip shown above. Started a few weeks ago, only affects 3 of 20+ pods I subscribe to. The error occurs on all episodes from these three podcasts including episodes I’d previously downloaded successfully. Things I’ve tried that haven’t fixed issue: re-subscribing via RSS URL, deleting app install and rebuilding subscription. Phone is Samsung j3 2017 with OS 8.1.0, app version 3.4.0 (5f5d744e7) downloaded from Play Store. Creators for these three podcasts say no other users have reported problems.

I’m having the same issue with another podcast hosted at blubrry.

It seems that it started around the time that the media.blubrry.com SSL cert was renewed.

I contacted blubrry support out of desperation, and I think they fixed it! I’ve been able to download again anyway.

1 Like

Me too! Thank you very much for your initiative!! :heart_eyes: