Cannot stream or download BBC podcast episodes over WiFi

App version: 2.4.2 (Google Play)

Android version: 12

Device model: Pixel 6

Expected behaviour: Download BBC podcasts

Current behaviour: This only applies to BBC podcasts. Podcast picture does not display. Podcast audio does not download or stream. Can view description and subscribe to BBC podcasts. I can view episode description text.

First occurred: new phone yesterday. Loaded profile by exporting database from old phone and importing it to new phone. Tried deleting a BBC podcast and resubscribing - it loaded episode list. Still works fine on old phone which also runs 2.4.2 but on Android 10. Podcast URL is identical on both.

Steps to reproduce:

  1. Stream or download any BBC podcast episode, or view podcast picture.

Environment: Nothing I can think of.

What error message does it show when downloading fails?

1 Like

Connection error.
Details: timeout

I tried disconnecting from WiFi and downloading via 4G. All the BBC podcast pictures loaded and I was able to download a podcast. Went back to WiFi and got Connection error again.

I just downloaded Dan Snow’s History Hit podcast (not BBC) - the episode downloaded OK but I got a “Read timed out” on the feed.

Same with RHLSTP. Downloaded the episode but timed out on the feed.

I should have mentioned that the episode timeout occurs after quite a long pause. I haven’t timed it accurately, but it’s about 30 seconds.

Sounds like there is something wrong with your WiFi network. The timeouts either mean that the network is extremely slow or that there is something like a firewall that silently drops connections to the podcast server.

I think there’s something wrong with my new phone.
My old phone works fine on the same WiFi network which has low latency and fast download.
I tried the Google podcast app on my Pixel 6, and that is able to stream some BBC podcasts but others, it just sits there buffering. Same with downloading episodes.
Could this be some kind of phone level content control? But then why would it work over 4G? I’m baffled.

If anyone comes across this thread, I think the answer is here:

It seems to be because it is a Google phone, access to BBC podcasts is restricted and you have to go through the BBC Sounds app.
It doesn’t explain why I get feed connection errors on some other podcasts using AntennaPod, so regretfully it looks like I am decamping to Google Podcasts. Apart from the inconvenience of shifting apps, it has a play until end of episode sleep option, a feature that AntennaPod could use.

That page you shared contains the following text:

Listeners will have difficulty accessing BBC podcasts via the Google Podcast app

So moving to Google Podcasts doesn’t seem to be a solution based on that article (?) Actually the ‘platforms’ the page talks about are things like Google Home/Assistant. But you can try of course and leave your AntennaPod as it is while trying out Google Podcasts.

This would theoretically be possible but something Google could do, not BBC. The fact that it works over 4G really points to an issue with the WiFi on your phone. The issue might be the DNS system, which translates a domain like into an IP address like 123.456.789.123 – and this could indeed be a problem that exists only on one of the two phones.

I don’t understand what is going on, but using Google Podcasts and BBC Sounds works.
I know the article only mentions certain platforms but it’s hard to know on a Google phone how limitations might spread across the phone. And the BBC thing is only part of the problem I have, with two other streams producing connection errors on feed update in AntennaPod.

Wondering if this is an consequence of the preparatory moves being made by the BBC to launch a pilot to make several of their most popular podcasts as BBC Sounds time-delayed exclusives?

(I think this in itself is worthy of a discussion and how best to respond to it - I for one will be making more use of get_iplayer to listen to those podcasts which include In Our Time, Inside Science and Friday Night Comedy)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.