Can't read rss feeds

App version: 2.1.4 (62b6ec121) from F-droid.

Android version: 11

Device model: Samsung A40

Expected behaviour:
Can update and add RSS feeds

Current behaviour:
Can’t update or add RSS feeds. The download fails and reports ‘IO Error: Operation not permitted’

First occurred:
27th of March. I allowed some Android updates on this day (this may be when I moved from Android 10 to 11, but I’m not sure).

Steps to reproduce:

  1. Update phone last week
  2. Watch download errors accumulate by themselves as my subscriptions are checked.
  3. Also can’t add any new feeds - same error

Pretty standard, I assume.

None of the 20-something feeds I use are working. I can still download podcasts from the existing feed data in my phone, but I cannot update any feeds.

As a test I tried reading one of my feeds using Escapepod and there were no problems at all. So, whether it’s a bug or not, the problem seems to be confined to Antennapod. I have no desire to switch away from AP if I don’t have to.

I’m not aware of any ad-blockers or VPN on my phone. Everything else is working fine.

Any help appreciated.

Could it be that your storage is full? Another thing to test would be to change AntennaPod’s data folder.

Well, my storage was not full - 3 gig out of 64 free, but if there are quotas of some kind I may have hit a boundary. Downloading podcasts still worked, so maybe that’s not it.

Switching storage to the less-full sd-card has worked though. Thank you very much! Hopefully the original location will work again after I’ve tidied up a bit.

1 Like