Crash when refreshing sources / Non-responsive widget

App version: 2.3.2 (but also in beta version; both from Google Play).

Android version: 9

Device model: Motorola Moto X4

Expected behaviour: Until two days ago, sources would refresh showing new available episodes.

Current behaviour: Crashes the app. I have tried reinstalling the app (after deleting data and cache), but no change. I have tried installing the stable version (rather than beta, which is what I had), but no change. This happens when pulling to refresh, or when pressing the refresh button. The app will otherwise still play available (already downloaded) episodes fine.

First occurred: About 2 days ago.

Steps to reproduce:

  1. Refresh.

Environment: No unusual settings. I download manually.

Hi @typhooncamel

Welcome on our forum and thanks for reporting a possible beta bug :slight_smile:

This sounds similar to the following bug in the first beta, which is fixed in the second beta, released today:

However, I’m a bit surprised that you say that the issue also occurs in 2.3.2. From your comment “it started two days ago” I would guess that the issue is related to an update; the beta that was released 12 September (3 days later you had the first crash). Google Play doesn’t let you ‘downgrade’ (but I don’t know what happens if you un- & reinstall and unsubscribe from betas in between). Are you sure you’re back on 2.3.2 instead of the beta and still experiencing the crash?

1 Like

I did downgrade by leaving the beta, uninstalling and deleting data, and then reinstalling. Having said that, I uninstalled, cleared data, and reinstalled the beta version, and I no longer have that issue, so it must have either been your fix or a problem on my end. Similarly, at the same time the widget stopped working altogether (removing and re-adding doesn’t do anything; skip back and forward buttons don’t appear; currently playing podcast does not show up; pressing anywhere doesn’t take you to the app), so I’m inclined to think the problem is on my end.

Thank you for your quick response and great app!

1 Like

Ok, good to know that’s possible, thanks.

I would guess that’s the fix in the second beta, then. Either way; happy the refresh issue is now resolved.

Did you manage to remove and add the widget again with the latest beta?

No, removing and re-adding the widget always produces the same (non-changed, i.e. no added buttons if you did choose to add them) and non-responsive widget (it doesn’t show what’s playing, pressing play won’t play anything, pressing anywhere doesn’t take you to the app).

@tonytamsf Since you worked on #4746, would you have any idea what could be the issue here with the widget?

@typhooncamel Could you double check you don’t have multiple widgets on your other pages?

I can confirm the are no other AntennaPod widgets. I’m using Nova, in case that may be a culprit.

I am perhaps having a related issue - Version 2.4.0-beta3 - Android 9 - LG G6. I too use Nova.

In my case the widget works fine but does not jump to showing the next episode after an episode ends. That is it still shows the icon of the previous episode and shows the time as fully done. When pressed it switches to the next episode then starts it.

I noticed this about a week ago but as my phone is “dying”, is at times acting inconsistently and I will soon be getting a new phone using Android 11, I thought it may be a residual error - however it continues after rebooting, clearing cache memory, etc.