Download error

App version: x.y.z (state whether from Google Play/F-Droid/Custom built APK)
2.6.2

Android version: 5.x (Please mention if you are using a custom rom!)
10

Device model:
Poco F1

Expected behaviour:
refresh downloads

Current behaviour:
Constant error and not downloading
the error says “The Podcast hosts server sent a website not a podcast”
First occurred: (e.g. about x days/weeks ago)
a month ago

Steps to reproduce:

  1. This just open the app and it starts to download and fails
  2. Then that
  3. Then this
  4. Etc.

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)
all default

Stacktrace/Logcat:

[if available]

Hello! To be able to help you, we need more information. It looks like this is a problem with an individual feed returning HTML instead of RSS. This can happen if the webserver hosting the RSS feed has an error. What is the feed that is failing?

1 Like

Actually happens on many podcasts.

this is one example:

The podcast host changed the ID of an existing episode instead of just updating the episode itself. AntennaPod still refreshed the feed and attempted to repair it.

Original episode:
Title: It Could Happen Here Weekly
ID: 9716e814-1804-11ec-a8a4-af899383fee3
URL: https://chtbl.com/track/5899E/podtrac.com/pts/redirect.mp3/traffic.omny.fm/d/clips/e73c998e-6e60-432f-8610-ae210140c5b1/78d30acb-8463-4c40-a5ae-ae2d0145c9ff/78b82738-3a7f-492e-b800-ae2d017633b6/audio.mp3?utm_source=Podcast&in_playlist=d64f756d-6d5e-4fae-b24f-ae280140ad36

God Damn it.

it won’t let me send you the rest of the message . It says new users can only send two urls or something. I tried to send it in couple of messages but it won’t let me do that either.

is this sufficient info?

@ByteHamster It looks like AntennaPod is not updating the FeedMedia table in the database when refreshing feeds. This is causing AntennaPod to continue to use the original URL, which is 302 redirecting to a URL which is itself returning HTML instead of media. This causes the error that OP is seeing.

That’s not an error, just a warning. AntennaPod still refreshes the feed and attempts to repair it.

I would be pretty surprised if it didn’t do that because it has been doing that for years, and we didn’t touch the code recently.

@fshuk Did you try another wifi network? The error can happen when there is something messing with your connection, like a captive portal, ad blocker, VPN, PiHole, WiFi login page, etc.

1 Like

I have 30GB limit on my 4G account. So I have tried it on 4G and not wifi. Same result. I actually have many subscriptions but the app does not seem to go through all of them before failing. It just seems to fail on one and stop