Error 403: The podcast host's server refuses to respond

App v 2.7.1 from F-Droid
Android v 11 on /e/ custom ROM
Fairphone 3

Expected: Play a podcast episode.
Current: Episode not played; above error message shown.

I’ve just updated my Android and my /e/, and then installed Antenna Pod (today).
Then I searched, in the app, for my favorite podcasts and have so far subscribed to 14 of them.
The only settings I’ve changed are what’s displayed in the drawer.

The first episode I selected to listen to didn’t work.
I hit “play” (ie stream) for the chosen episode, wait several moments, and then the above error is shown. Same results for other episodes of the same podcast; same result when I try instead to download the episode, and same again after I removed the podcast and then added its RSS manually.

Now I’ve given all 14 podcasts brief try, and 2 of them in total seem to have this same problem. (Note: they’re both from the same people!)

Can anyone help?
Thanks!

My guess would be that you use an ad blocker that blocks access to that podcast server

Thanks for responding!

  1. I haven’t installed any ad blockers.

  2. I made a mistake above: I didn’t get the app from F-Droid, I got it from App Lounge Store.

An alternative explanation could be that the podcast host misconfigured their server. Can you download the episodes? Please copy the detailed error message here (the one that appears after clicking the error in the error list).

I didn’t see a list of errors, and I didn’t click on any error.

I wasn’t able to download - same error message.

So now, I thought I’d reproduce the error for the 8th time or so, to see if I could click on the message for details, and guess what? Both those podcasts work fine now.

Just for a little more background: I stopped using Antenna Pod a while back to due problems I couldn’t solve (even with help in this forum). I finally figured updating my phone’s OSs would be prerequisite, but wasn’t able to do that until now! I had the same problems, back then, with other podcast apps, but not with Podcast Bean, which - aside from the fact that it worked - I didn’t like much at all.
Just mentioning this to say, I hadn’t had this error 403 with these podcasts on the bean app … but I guess all that is irrelevant now?
If there’s a next time, I’ll see what kind of detail I can get about the error before posting here.
Anyway, I’m glad to have my Antenna Pod back again!

2 Likes