Feed Download completed but size does not equal expected size

App version: 3.1.0-beta3 (Google Play)

Android version: 10

Device model: Nokia 7.1

Expected behaviour: Episode list is downloaded

Current behaviour:
Warning is shown:

Die Serververbindung wurde unterbrochen bevor der Download fertiggestellt wurde 

Technischer Grund: 
Download completed but size: 4554578 does not equal expected size 2277288 


Opening the feed in the browser works and shows something looking like valid rss.

First occurred: yesterday

Steps to reproduce:

  1. Retrieve the feed for https://geschichten-aus-der-geschichte.podigee.io/feed/mp3

Environment: Nothing special


After adding username and password for the feed some cache seems to have been invalidated and everything turned back to normal.

Since the introduction of the new download service I’ve encountered this error randomly spread over my podcast list. The fix above does not help at all. Also clearing the cache does not help. In total checking podcasts has slowed down noticeably.

Google Pixel 7a, Android 13

Removing the Podcast and readding does the trick.


Agreed. I encountered this issue for the first time earlier this week and that workaround was the solution.

1 Like

Still encounter this issue. The workaround with the username and password doesn’t work for me. Removing/unsubscribing the podcast and re-adding it would result in all the statistics and episoded to be deleted and I don’t want to download 300 episodes again, not even considering the fact that some podcasts remove their older episodes and I wouldn’t be able to download them again (whoever thought it would be a great feature to delete all podcast data automatically when unsubscribing).

Does anyone has some other idea on how to refresh the cache for the podcast?
Deleting the Android app data cache for AntennaPod doesn’t work either.

1 Like

For what is worth I think you can solve the problem if you delete files still present in cache folder.

On my phone the folder is :

I had a podcast failing to update feed and removing the only file in cache that was still there (and related to the podcast) solved it.


I tried this: it works! Thx!
Subsequently, all previously missing podcast episodes of a podcast appeared and could be loaded.

This did the trick. Thanks a lot!

Same issue here: currently I have to clear the cache folder every day. At least 5 of my about 30 podcasts get daily this red flag (wrong size) and become unusable.

This bug is really annoying.

The cache issue will be fixed in the next release (3.2)


I tried the same but it didn’t work. However, after clearing the cache and forcing a stop of the app, I got it to work. My main issue was that I couldn’t subscribe to a podcast, but now I’ve got it back.

It is a really annoying problem. It happens sporadically. And everytime I am loosing the statistics for the podcast.

Just remove cache files. (Look for my previous post) You won’t have to unsubscribe and lose your stats.
Issue should be be fixed in 3.1.1 by #PR6591

1 Like

Danke, das hat bei mir auch so funktioniert.
Ich hoffe aber, das ist nicht die “Lösung”, denn das kann bzw. sollte man keinem Nutzer zumuten, jedes Mal so umständlich den Fehler zu beheben. Ich hoffe, dazu gibt es einen Update Patch.

When will this release happen?

This issue kinda forces me to use another podcast app.

Can’t listen to any podcasts right now

Can I directly go into app info and clear cache from there or this specific path must be taken?

We did a bug-fix release (3.1.1) which solves this problem.

  • If you get AntennaPod through Google Play, please update the app.
  • If you get AntennaPod through F-Droid, please be patient - the app has been built and needs to be cryptographically signed by a person and then updloaded (this usually takes about 2 days).

FYI @Aman_Garg @Sheeperich @ThiNatz @stephen_titus_george @pjs012 @timbetu

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.