Global playback speed not reliable

AntennaPod version: 3.2.0 (58081fe5b)

Android version: 11

Device model: Blu G91S

Expected behaviour: When I set the global playback speed in the app settings, I do not expect it to change every time I change the playback speed on a specific podcast.

Current behaviour: Changing the playback speed in the settings for a particular podcast results in the app’s global playback speed setting to be changed to the speed set in the podcast.

First occurred: this behavior always occurs.

Steps to reproduce:

  1. Set the global speed to 90% and close settings.
  2. Select any podcast and open it.
  3. In the settings for the podcast, set the playback speed to 100%. Then close the podcast.
  4. Close and reopen the podcast and confirm that the playback speed is set to 100%.
  5. Open the app settings again and confirm that the global playback speed has been changed to 100%.

Environment: no changes were made to the environment.


[if available]
1 Like

I tried to replicate your problem. It seems to me that Global Speed setting doesn’t work at all no matter what you set it. Local speed settings doesn’t have to be changed.

Can someone else try to change Global Speed and confirm this bug?

If I set the Global Speed setting, then the next podcast played will play at that speed, even if I had previously set that podcast to another speed. So Global Speed does something. But not what is expected.

I set the speed for podcast A to 1x, podcast B is global default. Set the global default to 0.9 via the settings. Then playing A and B (both initiated from the Home screen) both play at 1x, while B is expected at 0.9 (the global default.

Makes me think of Trying to add New Playback Speed Gives Error · Issue #6728 · AntennaPod/AntennaPod · GitHub – maybe the fix had a negative side-effect?

I have the same issue and tried to analyze the root cause, see Global playback speed cannot always be set via app settings dialog, but is overwritten by feed settings dialog · Issue #6916 · AntennaPod/AntennaPod · GitHub

A post was split to a new topic: Turn off time stretching

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.