Hiding play controls on lock screen

AntennaPod 2.6.2 from Google Play
Android 12
Samsung S20 FE

I found a thread titled “play controls not appearing on lock screen with Android 12” and I thought that might help but it’s the exact opposite of what I want!
If I put my phone in my pocket while I’m out walking and listening to podcasts (which I do most days) then sometimes the screen turns on and the motion in my pocket then changes the playback - jumping forwards, backwards, stopping etc.

What I’d like to do is to hide the playback controls on the lock screen. I can’t see any option to set this but given that at least one user had this happen when they didn’t want it, I assume that there is some kind of toggle to turn this on/off. If it’s a case of using some kind of ADB command to set the option then that’s fine :slight_smile:

Hoping someone can help.

Thanks

Steve

I have had this issue and it is a “feature” of Android which is built in and cannot be turned off. I have two workarounds which can help

  1. Keep the phone in your pocket with the screen turn outward instead of inward against the thigh.

  2. Keep the phone in a belt holster.

Thanks; I was afraid that this was the answer!

Best wishes

Steve

Another option of course is to use a phone case with a flip front to cover the screen.

On my device, I can use Android’s notification settings to hide specific notifications on the lock screen

So do I but the settings seem to get ignored.

Edit: Had another play with the settings and I had to do the following to get it to totally behave

  • Turn OFF Double Tap to Wake
  • Turn OFF Lift to Wake
  • Turn OFF (Lock Screen) Always on Display
  • Turn OFF (Lock Screen) Music widget

But those features are so useful it would be nice if the Accidental Touch Protection feature actually worked.

Been playing with this a bit more today and found out that if you tap the clock on the Lock Screen then tap Settings it pops up the widget sliders which is a relatively easy way to turn the Music widget on and off . Next time I have pocket playback issues while out for a walk I will give this a go to turn the widget off temporarily then turn it back on when I reach the pub.

After further experimentation I have found that you also need to turn off Notifications for every media player in use to totally stop their play controls popping up on the Lock Screen. Not ideal for a podcatcher app when you want to be told about new episodes as they drop.

Edit: Ah! You just need to turn off the Currently Playing notification for AP - Other apps may call this Play or something similar. That way you continue to get the new episodes notifications.

EDIT: I forgot to add that I also use this Lockdown Mode app to instantly lock the screen before putting it in my pocket while playing something. Single tap to activate which is a tad easier than press and hold the power key to offer that option.

I still use Double Tap to Turn Off Screen at other times but when I do not want to lock it.

1 Like