Infinite unstoppable slow refresh on startup since upgrading

App version: 3.1.0 fdroid
Android version: 13 GrapheneOS

Since updating (almost sure not a coincidence, also never happened before) the refresh button is never shown, it’s already a spinner when starting the app.

Shortly thereafter, the ‘Refreshing podcasts’ notification comes up, BUT i don’t have automatic refresh enabled, and it’s never tried to refresh on app open before!


  1. Refresh is SUPER SLOW (compared to previous experience) and so far I have not managed to see it done (500+ podcasts subscribed), because a) takes too long, b) notification sometimes disappears, and c) notification sometimes resets the counter and it starts refreshing again from zero…

  2. In Menu>Downloads, there is not the usual line-by-line of podcasts being downloaded - which, besides being rather fishy, this also means I can’t stop the process.

Things I’ve tried:

Kill wifi mid-refresh. Just tries to start the refresh all over again as soon as there is wifi or as soon as I open the app again – argh!!

Clear cache - no effect.

Backup feeds/db, clear storage, and reimport → same problem again.

To make matters worse, I’m not on a very performant wifi, and the refreshing kills any possibility of using the connection, let alone listen to a podcast … so effectively I am locked out of the app (been using it for many years no problems).

Is this a known issue with the new upgrade? I found a couple of suggestive threads here but nothing definitive…

The refresh notification has a “cancel” button.

Oh yes, good point.

Tapping it does stop the unwanted refresh, and the spinner goes away but unfortunately upon restarting the app again it still tries again to refresh without having been requested to.

The manual refresh still doesn’t show podcasts as they are refreshed in Downloads, and it still seems excruciatingly slow as well.

That process resets the setting to the default, which is to do auto-refresh

If auto-refresh is enabled, it does one refresh immediately or when first starting after the upgrade. If you cancel the refresh or kill the app every time, it does not succeed and tries again the next app start.

Yes, about 3 times slower for technical reasons. Will get better when someone volunteers to implement Proposal: Smart Refresh Interval

I did disable the auto-refresh again after db import.

Seeing as the full refresh never seems to work anymore, am I FUBAR?

By the way, at least for me it’s not 3x slower, more like 20x. I have been unable to complete a single refresh after the latest update…

Also worth nothing is that the countdown of podcasts left to refresh actually resets and starts from ~500 (my # of subs) … i didn’t close the app, the notification showed it was down to 380 or so, suddenly it’s again 500.

Something seriously broken here :confused:

Still never managed to complete a refresh since, and still trying to refresh the entire feed every startup.

After 4+ years, app became unusable with the last ‘upgrade’.

Can I export the db to a pc and fix the refresh on startup loop somehow?

I mean, you could try to disable “keep updated” for all subscriptions for now. You can do that using multi-select on the subscriptions screen.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.