Memory leak?

App version: 2.5.2 (1bc02fd84)

Android version: /e/Solutions Murena Android 11 (/e/OS 1.1-20220627199800)… you’ll note this is a recent update, this issue occurred on the immediately-prior version, as well.

Device model: /e/Solutions Murena Teracube 2e (serial number: 2021 variant)

Expected behaviour: Top-of-window controls (back button, hamburger menu, 3-vertical-dot menu) continue to function

Current behaviour: After running AntennaPod for awhile, the controls on the top of all windows stop functioning. So the back button won’t work, in the Queue the topmost podcast episode play button won’t work, the hamburger menu button at top-left won’t work.

This happens to not only AntennaPod, but to all apps and all system windows. It doesn’t happen if AntennaPod isn’t run.

I switched from Bliss Launcher to OpenLauncher to ascertain if it was a launcher issue… while it takes longer with OpenLauncher for the behavior to occur, it still occurs. Again, it doesn’t occur if AntennaPod isn’t run.

First occurred: 26 Jun 2022 (after installing AntennaPod) and repeatedly since

Steps to reproduce:

  1. Boot the phone

  2. Run AntennaPod and listen to podcasts (this may require continual running of AntennaPod for as much as 24 hours before the issue occurs, apparently depending upon which launcher you’re using).

  3. Eventually the controls at the top of all windows will stop responding, almost as if the top 1/2" of the screen goes dead… but I can still swipe down to get the large menu where one turns on and off Mobile Data, WiFi, location, etc… and that continues working, so it’s not the screen itself.

  4. Reboot the phone to restore functionality.

Environment: 130 podcasts (not sure if that affects it or not), Airplane Mode off, Mobile Data off, WiFi on, listening to podcasts while the phone is plugged into USB, refreshing podcasts every few hours. 3-button navigation enabled (swipe navigation disabled) on phone.

Stacktrace/Logcat:

Not available.

It is highly unlikely that this is caused by AntennaPod. Android separates apps from each other. Even if AntennaPod had a memory leak, the Android system would close it without any effect on other apps. To me, this sounds like your screen is broken.

But as I stated, I can drag down the top menu, the one with WiFi, Airplane Mode, etc… it works even at the top of the menu. It can’t be the screen… and it works fine after a reboot.

I’m doing some testing. I’m running AntennaPod, but not playing any podcasts first, while recording the time for this issue to recur.

Then I’ll reboot, and play audio-only podcasts while recording the time for this issue to recur.

Then I’ll reboot and play video-only podcasts while recording the time for this issue to recur.

Huh, if I go into Settings > Apps & notifications > See all apps > AntennaPod and Force stop the app when this problem occurs, it partially fixes it.

Upon restarting AntennaPod, the hamburger icon at the top-left of Queue works again, although the ‘Play’ button on the first episode listed won’t work… tapping it opens the window with the “Play” and “Delete” buttons.

The ‘3 vertical lines’ button at top-right also doesn’t work even after Force stopping the app and restarting it, until the phone is rebooted.

If a reboot fixes it but a force-stop doesn’t, this is definitely not caused by AntennaPod. Something is odd either with your hardware or with your Android system.

What about if you do a Force Stop then Clear Cache? If there is some kind of memory corruption that should clear it.

BTW Do not do a Clear Data as that will lose all your subscription / episode informaton.

Next time the issue arises, I’ll do that, gomezz. Thank you for the suggestion.

Ok, I tried doing a Force Stop, then a Clear Cache. No effect, the issue persisted at the same level (the hamburger menu upper-left started working, but nothing else at the top) until the phone was rebooted.

Heh, I guess I should have tried this before, but I didn’t. I found that simply turning off the screen, waiting a count or two, then turning the screen back on fixes the problem… so it appears to be a graphics subsystem memory leak.

1 Like