New audio clipping issue

AntennaePod 2.5.2: x.y.z (state whether from Google Play/F-Droid/Custom built APK)

Android 12 CalyxOS 3.5.1: 5.x (Please mention if you are using a custom rom!)

Pixel 4a:

Normal Audio Playback:

I am getting a lot of audio clipping in very strange ways. It sounds like an automated program has gone through my podcasts and tried to eliminate long pauses, which results in clipping of the very end of words and a very robotic, clipped together sound. I am playing back at normal speed. This occurs on multiple difference podcasts, but not all of the podcasts I listen to. The weirdest part, is it seems to effect certain people who are speaking a lot more than others on the same podcast. It is like one of the people has some blank noise cancelling software on their recording and others on the same podcast dont. And it is happening on at least 4 different podcasts, so it makes me think it is in the Antennaepod app. I am completely open to the idea that this has nothing to do with AntennaePod, but I am mostly looking for confirmation that someone else is experiencing this also. It is making me think I am crazy, or that some deity from PKD’s The Divine Invasion, is messing with my phone. It started a week or two ago. I listen from autodownloaded:

a week or two ago: (e.g. about x days/weeks ago)

Steps to reproduce:

  1. Play from Downloads
  2. Then audio has clipping
  3. Then I go a bit crazy, and stop listening

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)
Auto Download. ExoPlayer

Stacktrace/Logcat:

[if available]

Sounds like you enabled the “remove silence” option on the playback controls dialog (settings button on the player screen)