Newbie question: Restart after interruption

App version: 2.6.2 (F-Droid)

Problem you may be having, or feature you want:
I started to listen to AP for podcasts when running, but I also used an app called Zombie Run!, which cuts in every kilometer or so with its own audio file for a minute or two (it is a running/storying telling app).

AP will pause for the interruption. Works well (and in line with the option under playback).

My problem is that AP does not restart after the interruption. I would like it to go back to my podcast as I can not stop running to take out my phone and push the play button each time.

Is there an option I am missing? Is this a feature request, that I did not find on the forum.

Any help welcomed.

I would like to find a solution so I can use both apps at the same time without having to access my phone.

I think this is a feature request now.

Basically, I played with it and I think it is the timer set for the Pause-Restart. It is too short. If the audio break is 30 seconds or less, it will restart without any issue. Longer, it just stops.

Is there some way to change Pause-Restart timer or change the default to say a 1’30"?

I have no idea if this is also a problem with incoming calls.

Still no solutions.

Any thoughts?

To reproduce.

  1. Install Zombie Run! And AP
  2. Start podcast
  3. Launch a ZR! Mission and listen to audio clip
  4. See if AP podcast restarts (it will not)

If audio clip is less than a few seconds, it will restart

To reproduce

  1. Same
  2. Launch a ZR! Supply mission, listen to start
  3. Launch a podcast
  4. Walk around until you hear “you picked up …”
  5. Podcast restarts

Hi @Hillmanae
Thanks for chipping in to the AntennaPod community. Sorry no-one replied before.

Normally AntennaPod should resume after it’s been interrupted by another audio source, like navigation or your zombie app. Sometimes apps don’t ‘give back’ the audio channel after using it, playback in AntennaPod is not resumed. But the fact that playback restarts if the clip is only a few seconds seems to indicate that this is working like it should.

Because it doesn’t work if the zombie clip is a bit longer, I’m thinking that it might be a memory issue on your phone: after a while of AntennaPod not being used your phone might kick it out so to say, to free up memory space, after which AntennaPod doesn’t restart itself. Might this be a viable theory @ByteHamster, @tonytamsf?

One thing you might check if you haven’t already, is to add a battery exception to AntennaPod.

On a side note, there’s one relevant setting, under Playback > Interruptions: Pause for Interruptions

Thank you for the reply. Very kind.

I have given both AP and ZR an exception to the battery optimisation rules but it doesn’t make any difference.

I have Amazon Music and it does restart after an audio clip from ZR on my phone (for info: Oneplus 9, Android 12, OS).

As the basic ZR! Is free, maybe someone else would be so kind and download and try it. Maybe it is just my phone, but it seems odd.

For info: the average audio clip of ZR! Is around 2 minutes on a mission. It is 15 seconds for a “supply run” audio clip

On AP, makes no difference if “pause for interruptions” is on or off, other than on the supply run clip where both overlap when off. There is no overlap on the mission audio, only the zr mission audio is played.

Thanks again for the reply.