Only want to stream not download

Does anyone know why I can’t stream podcasts, just download them? I subscribe a podcast, click on the specific episode, and 2 options come up - download or stream. When I select stream, the “play” screen comes up, but when I hit play, nothing happens.
I don’t have wifi at my house, and don’t want to use up all my data to download every single episode I want to hear. Am I missing something? It’s probably some basic setting somewhere that I’m looking straight at but not seeing :confused:


As far as I know, AntennaPod should start playing automatically after pressing “Stream”. This might take a few seconds, depending on your internet speed. My first guess would be that when pressing the play button manually, AntennaPod is somehow confused and stops streaming again. Could you please try to press “Stream” and then just wait a few seconds?

I’ve tried several times in several settings with several podcasts, and it doesn’t work. I just get this completely blank screen. Maybe it’s my phone? I have a really basic Samsung LG. My husband has the Galaxy S10 and had no problems at all using AntennaPod.

P.S. Once I clicked the play button and waited for over an hour for anything to happen, and nothing did, so it’s not that either :confused:

Hmm. When you tap on ‘stream’ there should at least be the title (as well as the image and total length) in the play screen you’re seeing. So the fact that it’s empty indicates something is off, even before streaming starts. This might actually be a bug. Can you provide some more details?

App version : x.y.z (state whether from Google Play/F-Droid/Custom built APK)

Android version : 5.x (Please mention if you are using a custom rom!)

Device model :

Environment : (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)

Looks like you use mobile network. Could you please try using WiFi? By default, AntennaPod warns about streaming over mobile network to prevent accidental data usage. In some versions of AntennaPod, the warning might be overlooked easily (only in the notification area).

If using WiFi also does not work, this is probably a bug (as keunes noted)

I think I found the solution! In Settings >Network>Mobile Updates, I selected “Streaming” and it seems to work now. That was a lot of effort for a non tech-y person like myself though, so I probably wouldn’t recommend this app to anyone like me. On my husband’s s10, he got a pop-up notification “would you like to allow streaming over mobile data?” And was given the option to click “allow.” I didn’t get that, and had to hunt it down on my own.

Keunes, I downloaded the app through Google Play about a week ago, but am not sure how to check which app version it is. My phone is an Android 6.0.1, Samsung LG-M153. I didn’t change any settings, until I found the one mentioned above :slight_smile:

Thanks for all your help and interest!

That’s great to hear!

In version 2.0.0 (which will be released soon), the message will be a lot more prominent:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.