OPML - Password - Auto-Download - New Episodes

Hi!

I have just installed AntennaPod and am in the process of testing it out with the intention of switching to it from Doggcatcher that I have used since 2012. No marks against Doggcatcher but it has not been supported for over 2 years and appears to have been abandoned (no forum entries by creator, etc.). Also I much prefer open source!

I am running the two in parallel for now and have found the four issues (my mistakes, limitations or true bugs) listed below. Only one issue, Auto-download not working, is major. I am a LINUX user (exclusively since 2008) and am familiar with gpodder.

Phone: LG G6
Android: 9
Other: Am a Beta user (Version 2.1.2); Use AdClear (Internal VPN); Use Nova Launcher

Setup Issues:

OPML - minor issue with workaround
The OPML from Doggcatcher was not accepted. I had to enter the URLs separately

Password - minor issue with workaround
My one subscription that requires a username and password would not accept them. I found a workaround by adapting the url to include the username and password - this worked (FYI - https://name%40email.com:password​@url)

Operational Issues:

Auto-download Not Working - major issue (IMHO)
I have set it for hourly but even after 12 hours none are downloaded. I have checked that each subscription does not have an override. Set Parallel to 10, and also flipped from Internal Storage to SD and back. I monitor my Doggcatcher and then compare - once I do a manual download they all appear.

New Episodes - inconsequential purely FYI, may not even be an issue
Under Episodes,New they show up only while being downloaded - it is Queue that is functionally useful. However this may be by design.

Thank you so much for your support. Once I am better versed I hope to join you in assisting others and the project itself.

1 Like

If you send me an email with the OPML, I can have a look at why it was not imported. My email address is info@<my user name>.com

Did you have a problem with streaming or did subscribing not work at all?

I think AntennaPod only auto-downloads new episodes

The idea of “new” is to mark episodes that you have not interacted with at all. So when downloading or adding them to the queue, they are no longer “new”. They are still unplayed, though, so episodes can have 3 states - new, unplayed, played.

Thank you very much for your extremely quick reply, ByteHamster!

  1. OPML - Will send via email

  2. Subscribing did not work at all - it asked for my username and password, which I entered (multiple tries) and it did not accept, simply asking for them again. Will send via email info about the workaround.

  3. There were new episodes in multiple subscriptions during the periods, as found and downloaded via Doggcatcher. Only showed up in AntennaPod when done manually.

  4. OK - so will show as new only if found online (via WiFi or via Mobile Updates, where I have flagged “Podcast Refresh” & “Cover Images”). That’s good. This may be a hint in solving the auto-download issue as there were none listed in New Episodes - they only show up there, momentarily when I download manually.

Again - Thanks so much!

The opml file imports just fine on my device. Did you get any error message?

Unfortunately, I can not really try that podcast because I do not have an account. If you send me the password (via email, not publicly, obviously), I can have a more detailed look.

Exactly. That screen is made for deciding if you are interested in episodes. If yes, you can download them or add them to the queue. If you are not interested, you can just swipe them away to mark them as “not new”. They are still unplayed, it just stores the fact that you have decided what to do with them :slight_smile:

OPML - I did notice an error but there was a message that it was unacceptable or not an opml - sorry don’t remember exactly and as I have copied all the url’s over individually I don’t want to retry - however am willing to re-install if it would be helpful. Could it be because there are “virtual” (ie folders on the SD card) feeds? Please advise.

Password - Sorry, not that I don’t trust you but I have problems with giving out such access. As there is a workaround, and even the podcaster acknowledges that some podcatchers don’t accept his site’s passwords (as per the link I sent you privately), I see no need. However, if it would help you in improving the app, I will give it but will change my password after a very short period. Please advise.

New Episodes - Understood!

Auto-Download - This is my central issue, is there any further info I can provide that can be of help? If required to assist you, as mentioned above with OPML, I am willing to re-install. Please advise.

However I am not always available, nor am I as quick in response as you are. There may be a delay before I can assist if required.

When importing the OPML, AntennaPod first shows a list of the podcasts within the file. If you don’t press the “OK” button there, nothing is imported (so you don’t need to re-install or change the subscriptions). Would be great if you could try to get to the preview page to get more details about the error message.

I don’t think OPML and local feeds interfere.

It could maybe help to find out what went wrong there, so others do not have to use the workaround. If you are not comfortable passing around passwords that is totally fine - I can understand that.

To clarify, do you really mean automatic download of episodes or do you mean automatic feed refresh? If new episodes don’t even show up, the problem is feed refresh and not auto download.

I’m not always that fast :slight_smile: This was just luck earlier

Thanks once more, ByteHamster!

OPML - Issue closed!
Tried it again and no problem this time! Got the list as you described - even checked on one (a virtual one) as a test, which it accepted but failed on the download. Problem solved due to “FM”! FM is an old (1970’s) terminology used by IBM CEs when they showed up to fix a hardware problem on the IBM 370 installation I managed, and the problem had disappeared by the time they came. Same reason the funny sound from your car’s engine isn’t there when the expensive mechanic is listening for it. Can explain via email if you’re curious!

Passwords - Later
I will write the podcaster in question tomorrow (bedtime for me now) and see if he’ll provide a temporary username/password for test purposes. Will be in touch via email.

Auto-Download - Feed Refresh
New Episodes do not show up at all, so it is a Feed Refresh issue.

1 Like

Feed-Refresh - SOLVED
As mentioned I have AdClear internal VPN. After searching the forums for “Feed Refresh”, found you questioning in one thread if the person with a similar issue had a VPN or a Firewall (neither was their problem). Switched mine off for AntennaPod and bang, the episodes started appearing!

So only issue left now is about the Password - will be in touch via email on a way to test.

Thanks so much!

2 Likes

Nice to hear that most issues are already resolved! :slight_smile:

Yeah, I know that kind of problem :smiley: What does the abbreviation “FM” stand for?

Replied about FM via email - not for the forum. Also emailed the podcaster whose password is not accepted to try to get a temporary username&password.

The temporary username and password seem to work just fine on my device. Could you try adding them on your device? As you already use the workaround which has a different address, you can add the podcast a second time using the “normal” subscription address.

1 Like

OK - I’ll try once I receive it via email from you - the provider didn’t cc me! Nonetheless awfully nice of him to provide it!! Sounds like another case of FM!!!

In any case with all my playing, I plan to delete the app from my phone along with all its data and reinstall clean. Maybe by doing so the OPML and Password problems I had originally will disappear, again due to FM. Or - perhaps the problems only occur on a fresh install being used the first time, before any reboot? Another possibility is that the VPN also affected the OPML and Password functions (just a guess but could be). I will therefore immediately on the reinstall turn off the VPN for it and then reboot. I will take careful notes of what occurs and report back.

Yes - I am having fun! Being retired, and having a busy but different life, it’s been many years since I enjoyed the bug hunt!

I replied to the provider and CCed you. You can find the password below my message.

Actually, I don’t think a fresh install will change anything here :slight_smile:

Yeah, that could be the case.

Thanks for forwarding the test username&password, but it still doesn’t work. Reminder that I am using the Beta version - is this an issue? However, I still suspect the VPN.

We solved my Feed Refresh problem by me turning off the “Ad Blocker” feature of the VPN - its other major feature is a firewall, which was already off (my default). I tried the test password while the Ad Blocker was off and as before it just kept on coming back asking for the username&password. I tried it again after a reboot and just to be sure, a clearing of the AntennaPod cache (via App Info) - still didn’t work. Then I turned off the VPN itself and once more no go. I then turned off the automatic restart of the VPN and after the reboot & clear cache process still no luck. However, I think we are on the right track about the VPN. I can delete its app fully and try again, but as installing and setting up the VPN is not simple and there is a workaround to the problem, I’ll leave that for when I eventually get a new phone!

I’ll take a break now, unless you have any new ideas for me to try. Time to enjoy my podcasts while walking my husky through the hills of the Galilee. As mentioned, within a few days I plan to do a full reinstall of AntennaPod in order to clean out any remnants from this testing and my own playing around to learn the app, for instance going back and forth from internal and SD card storage. Will report then if there are any changes, but for now I consider this item as solved, and will mark it as such at that time.

1 Like