Paid RSS feed

Hey folks. I’m wanting to switch over from Podcast Addict, and was able to import my podcasts via OPML import, which is excellent. One of my paid feeds worked, but the other didn’t. I went this route because I wasn’t able to add either paid feed within AntennaPod before.

I’ve tried to add it manually a few times, but after entering the username and password, it does nothing. The prompt disappears and I’m on the “add podcast” page as if nothing happened. I’ve tried minor variations to the URL but this, naturally, shows up as an error.

This is the feed, and it works fine in the other app.

https://www.crrow777radio.com/feed/paid/

Thanks for your help.

I am one of the contributors of AntennaPod. If you open that link on your browser and enter the user and password, does it work and display an RSS feed?

I also tried the feed by entering a bad user and password and nothing happened.

I am not sure how best to proceed, but it sounds like a regression.

1 Like

Good idea. I tried that in Firefox, and was offered an RSS (.rss) file to download, so I guess it was the feed, as my username and password worked.

@trance does that work the same way in your browser (file download) for the other feed that does work in AntennaPod?

It does, actually. Interesting.

@trance what you are seeing seems like a bug. Could you do us a favor and file a GitHub issue on this problem? I am surprised this has not been reported by other people.

if you are able to change your password, it would be good for you to give one of us via private email the user and password for us to test and then you reset your password so we cannot use it after we verify the bug

1 Like

@trance could you test one more thing?

Using the following format, you can try to download a feed with the username and password already filled in

http://[username]:[password]@[domain]/[path]

Could you try to open the url with your username and password in the url using

  1. your web browser in incognito mode, this should not require a password
  2. then the same url using AntennaPod?

https://[username]:[password]@www.crrow777radio.com/feed/paid/

1 Like

So that works, thank you. I was able to subscribe.

thanks @trance . it is still a bug we need to fix. I am on vacation right now, and cannot confirm the bug. @keunes just a fyi that this could be a potential bug

1 Like

@tonytamsf Any vague clue what it might be? Should I create a GH issue?

Enjoy! :parasol_on_ground:

I am surprised no one has reported this problem yet. I think we can wait until someone else reports it.

when I get back, I can try to reproduce it.

I’m sure it did work at some point because I changed the “set password” UI some months ago. If it had been broken then, I would have noticed. I can confirm that it is currently broken on my device, too. Strange.

As a test feed, you can use this: Password protected media. Username: user, password: password. When downloading the media file, I get an error message. When adding the credentials and streaming the file, it works. So there must be something wrong with our download service.

Adding some logging to BasicAuthorizationInterceptor, AntennaPod sends the header authorization: Basic dXNlcjpwYXNzd29yZA==. The following command does fetch the file just fine:

curl -H "authorization: Basic dXNlcjpwYXNzd29yZA=="
    https://tools.bytehamster.com/podcast/pianoPasswordProtected.mp3 > test

No idea why AntennaPod doesn’t do it – with the same header.

I think I found it! The problem is the http»https redirect. If the request is redirected, we apparently don’t send the header to the new URL. I added a second item to the test feed that shows the difference. Unfortunately, I don’t know why the headers disappear…

1 Like

@trance Which AntennaPod version do you have?

GitHub issue created: http»https redirect missing (password/authentication) header on download · Issue #5214 · AntennaPod/AntennaPod · GitHub

And what a lovely piano music @ByteHamster :smiley:

1 Like

It’s not played by me, sorry :smiley: I do play piano, though.

1 Like

Just installed it the other day. 2.2.1

Doh, of course. I forgot, sorry. Thanks :slight_smile: