Play controls disappear on Pixel 7 pro Android 13

App version: 2.7.1 Play store
Android version: 13
Device model: Pixel 7 Pro

Expected behaviour: When playing podcast the play controls appear in the Android notification area and on the lockscreen. When tapping the play controls they do what they should (play pause, advance rewind), when tapping the title in the notification area Antennapod opens.

Current behaviour: Antennapod appears in the notification area when playback is paused. Once playback starts the controls disappear. Have to open Antennapod from app drawer or from task switcher in order to pause/stop, fast forward, rewind, etc. Playback controls don’t appear on lockscreen either. When playback is paused the controls appear and buttons work but tapping the title doesn’t open Antennapod, nothing happens.

First occurred: About 3 months ago or more, was happening on Pixel 6 Pro before I upgraded phones

Steps to reproduce:

  1. Launch Antennapod and start playing a podcast.
  2. See that the controls in notification area and lockscreen are missing
  3. Launch or switch back to Antennapod and pause playback
  4. See that the controls now appear in the notification area
  5. Click play
  6. Control card disappears

Environment: Nothing that I know of. The controls for other apps like youtube, youtube music, etc are persistent and work as expected.

Stacktrace/Logcat: Not available currently. Am not rooted for aLogcat app and don’t have SDK installed on pc yet. Will work on capturing

2 Likes

Interesting. It’s the opposite of normal/intended behaviour. So if I understand correctly, the notification remains, but the pause/forward/etc buttons disappear?

Does changing the ‘persistant controls’ setting have any effect?

Sorry for being unclear, the entire notification disappears. And now that I’ve been paying attention its fairly inconsistent. Sometimes the behavior occurs and sometimes it’s fine and works as expected. I did try to turn off and on all the notification settings in Android app settings. Just turned off “Persistent Playback Controls”, quit Antennapod, turned back on. Will keep an eye on things

1 Like

I am also having a problem with the playback controls not showing up on my lock screen on my Pixel 7. On my lock screen I don’t see an icon or any of the controls. My Pixel 7 settings are setup exactly the same as my Pixel 5a that was working perfect. This problem is so annoying I’m debating returning the phone. Please tell me this can be fixed.

This seems to be potentially related to or even the same as (some reports in) Player in the notification shade disappears if interacted with while app is in background · Issue #6049 · AntennaPod/AntennaPod · GitHub

Virtually anything can de fixed or worked around with enough time or other resources available. :wink: Not sure if there’ll be someone like that (very) soon, though.

I don’t think that’s the same problem. I use to be able to pause, forward and go back while the screen was locked. Just double tap the locked screen and the controls would show up without unlocking or swiping down. This was extremely useful convenient.

I think @kuenes was replying that my problem is related to the Issue #6049 and I do think its the same thing. I’m going to pay more attention to whether having Antennapod on screen when interacting with the “notification shade”, didn’t know that was the name, has an effect on whether it disappears or not.
I think the lockscreen issue is here from 2020 but people have reported it in 2022 as well on Android 13. Might be good to watch that issue.
Lock screen controls disappear on Android 11 #4448

1 Like

The “in the background” made me think of checking the battery optimization settings and I think its semi-fixed. By disabling battery optimization so that AntennaPod is now set to “Unrestricted” the behavior no longer occurs. The notification shade remains no matter if Antennapod is open on screen or in the background. Play controls remain on the lockscreen as a notification shade as well. The issue now is that it can’t be swiped away even after a podcast has completed and the queue is empty but that’s better than it disappearing all the time.

1 Like

Pixel 6a, Android 13… Setting the battery optimization to “unrestricted” has not solved the issue for me. The audio notification in the pull-down notifications, and the audio notification on the lockscreen all disappear when interacted with. Even when the app is in the foreground this behavior exists.

Note that normal audio functionality (pause/resume) via bluetooth controls work fine; other audio/video apps (VLC, youtube, etc) work fine from the notification area… Edit: those other audio/video apps do not have unrestricted battery access (they’re all set to optimized) and don’t display this issue.

If I get some time later I’m going to do some debugging and see if I can find out what’s going on…

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.