Playback pausing itself

App version: 3.4.0 (Google Play) (state whether from Google Play/F-Droid/Custom built APK)

Android version: 12 (Please mention if you are using a custom rom!)

Device model: Ulefone Power Armour 14

Expected behaviour: Podcast plays until you stop it

Current behaviour: After a minute or so, playback pauses. Pressing play starts it again, and after a minute or so it pauses again

First occurred: (e.g. about x days/weeks ago) Since I first installed it

Steps to reproduce:

  1. Press play
  2. Wait about a minute

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)
Tried with Android Auto (in several vehicles), with bluetooth speakers, with wired headphones, and with the phone speaker - the same thing happens every time. I am using the default settings.

I started using AntennaPod last week since Google has shut down their service. Every time I try to use it, I get a minute or so of playback then it pauses itself. I press play, it plays for another minute or so, then pauses again…

I did a search and I found a similar topic from a few years ago where the person solved the issue by force shutting down the app and clearing the cache. I tried this and it seemed to work - but after 2 days the issue started again and now it doesn’t seem to have any effect.

I found another similar question where somebody mentioned the “pause for interruptions” setting - I have tried changing this and it has made no difference.

I did not have this issue with Google podcasts, and I can play music with a different app without any issues so it seems like it must be something specific to AntennaPod.

I also did see the note in the documentation about adding AntennaPod to the list of exceptions from battery optimization. I have done this and it has made no difference.

Thanks in advance for any advice anyone can offer.