Player audio randomly stops - but seekbar continues progressing

Environment

Android version: 9
OS version: 4.4.148-perf+
AntennaPod version: 3.3.2
Model: G8441
Device: G8441
Product: G8441

Expected behaviour:
Continuous smooth playback

Current behaviour:
Audio stops but file continues playing

First occurred: Yesterday (2024-05-05)

Steps to reproduce:
Don’t know - seems random.
Keep player running for some time.
First time it happened in 10-15min. Others took maybe more time.
I was navigating the app config (mostly gestures).

Pressing pause/play doesn’t fix it.
If i move back some seconds audio will resume and it’ll continue playing past the time it stopped

Environment: was playing in BT earbuds (only tried these; had no issues in Google Podcast)

It also happens to me. I’m on Android 14 (P7P). The pod will be playing normally and the audio cuts out completely but the timer keeps going. Didn’t know to correct it the way OP did. What I was doing was force closing and clearing cache and when I’d fire antennapod back up it would work fine. The issue might happen just minutes later again, or it might not happen until the next day or maybe the next pod. I can’t figure out what’s doing it. I don’t think any notifications are causing it, but I haven’t completely ruled that out yet.

Another observation is that it never happens if I’m casting a pod to a speaker. It’s only while playing on the phone, which makes me think some sort of audio event, like a notification, is at the root of the problem.

Happened again today, while in pocket, locked, with screen off.

Same earbuds
oh, besides the earbuds i’m always with my Mi Band 7 Pro which also connects to the mobila via BT

Update:
This morning, audio stopped 2 times.
On the second time, my previous workaround to regain sound didn’t work (i«use seekbar / press button to rewind or advance some seconds). Had to force stop app and clear cache for it to work again.
At this point, I have experienced the sound stopping issue every time I have used the app…
All the times I have used it, I never downloaded the file beforehand (it was streaming directly)

Before the afternoon commute, I decided to download the next 5+ podcast prior to download listening.
So far, still playing with no issues (first time since I started using the app, which was this weekend).
Will do this for the next days to confirm in hopes of helping to narrow down the cause of the issue

I have the same problem but I think I have narrowed it down to signal dropout issues.

On my commute there are large areas of signal blackouts which result in this behaviour but in slightly different ways.

About half the time, playback pauses whilst it tries to load/reconnect and then when I return to signal it restarts from that same point where it stopped (arguably the correct/expected behaviour)

The rest of the time, when I hit these areas then instead of pausing/buffering, the audio will cut out but the podcast keeps ‘playing’ (the time advances etc). When the signal returns, then either the podcast audio will restart but from the later time, or the audio just doesn’t restart and the only way to get it to play is to force close and restart the app. Pressing play starts it from the ‘later’ time (ie when the app was force closed not when the audio cut out).

If the playback was paused for a phone call and then I enter the area without signal without enough time for the audio to resume, then as above, the audio doesn’t play but the playback continues as above but never will return without a force quit as above.

This is whilst connected to car Bluetooth.

Weekend update.

Since I started downloading episodes I have had zero instances of audio stopping.
So the issue must be related to the way the app caches / buffers / streams.

My commute is by bike, for about 30min/7km in Lisbon (capital city) center or riverside (should be about the best network coverage in the country). There are no network blindspots (at least not significant). There are no tall buildings or anything else blocking signal. This issue never happened with other apps (at least not in Google Podcast, Edge or Brave)

I have recently started seeing something similar: For almost every episode I play (streaming) the audio stops after about 15-20 minutes. The timer keeps going. If I select another episode in the queue it plays fine, but again only for the first 15-20 minutes. I can keep doing this with a new episode but if I try selecting one of the previously stopped episodes again I most times simply get an error message.

Same here. Not sure if this happened after my Android 14 update but the audio stops during stream but the play button still runs and I get this message:

I don’t get that specific message.
I noticed (at least in my device) that streaming seems to be handled by Android System WebView.
I uninstalled all updates and cleared data.
I will try streaming (with no downloading) these following days.

Same for me. I can download the episodes with no issue.

That worked. I cleared the cache in Android System WebView and no problems since. Thank you for the tip.