Search on fyyd seems broken: IllegalArgumentiException

App version: 3.4.0 Play Store
Android version: 14 HyperOS
Device model: POCO F5

Expected behaviour: Search on fyyd should work

Current behaviour: When searching on fyyd from the “Add podcast”->“Search on fyyd”, any search returns the following IllegalArgumentiException error

Steps to reproduce:

  1. Open “Add podcast” section
  2. Tap on “Search on fyyd”
  3. Search anything

I see this too. I bet fyyd did the thing developers should almost never do - change public APIs.

Maybe it’s time to – eight years after it’s introduction – remove support for Fyyd search.

@ByteHamster didn’t you also say that Fyyd contained a lot of spam/duplicates nowadays?

Well, that’s not a bad thing per say, as long as API versioning is supported.

Removing fyyd makes me a bit sad… :smiling_face_with_tear:
Years ago I often used fyyd to upload small podcasts so they can be found in AntennaPod, too. For example, some “underground” tech podcasts that refused to join the iTunes index.
Anyway I understand your reasons and nowdays I suppose “podcast index” is a better choice

2 Likes

That was gpodder.net. fyyd is managed fully manually.

That looks more like a problem introduced during AntennaPod dependency updates, not like an API problem.

Maybe. In my experience, it works quite well especially for German podcasts (where we have our largest user base). Maybe we can retire it as part of our default search engine but I wouldn’t throw it out completely for now.

1 Like

Interestingly enough, it seems to be working in the current development version, just the release version is broken

Ah, then never mind then :innocent: