Skip intro settings hidden?

I’ve been using A’pod for years, and I know that settings are … kind of extensive, and sometimes hard to locate. But here is one I must have used/set in the past, and I just can’t undo it. My player is obviously set to skip 30 seconds into every podcast and I can’t get rid of this - I want 0 secs skip at the beginning and end.
I went through every settings dialog 5 times, no joy - I cannot find it. Please help!
Antennapod 2.1.0 on Android

It is odd that you are skipping all podcast if you did not set this. Here is a way to check

Go to subscriptions
Open the podcast you have a problem with
Tap the gear / settings for that podcast
You should see Auto Skip
open that and change the Auto Skip first

1 Like

Not a bug, it was … as expected … a setting I simply couldn’t find. Since it had happened in any podcast listened to, I thought it must be located somewhere in the general settings. Once you pointed me to the subscription specific settings (which I had forgotten about) I could turn it off. Thanks a lot !

2 Likes

Glad you figured it out or else you loose the 30 seconds of your podcasts, not a good thing :wink:

1 Like

If I may I’d like to chime in with related question - I never figured out when the Auto Skip actually kicks in. When I set this on Podcast level, does it imediatelly apply to all downloaded episodes of the given podcast that are in the queue or only to the new ones (downloaded after the setting was changed)? I tried to observe the behavior and it was kind of confusing - some episodes of the given podcast skipped, some not and I never really found the pattern. Does anyone know how exactly this actually work? :slight_smile:

Thank you.

As a non developer I would expect that skipping intro is triggered when starting to play an unlistened episode or when starting to play and current position is less than number of seconds to skip.
Isn’t it what is happening?

I tried with one of my podcast :

  • set intro skipping to 30 secs : episode already downloaded and never started, no problem
  • stopped episode, changed intro skipping to 45 secs : no problem additional seconds are skipped
  • downloaded an episode : it respected skip settings
  • turned off intro skipping : everything works as expected
1 Like

Thanks a lot @Matth78. Agree this is how it should work - I just noticed there are podcast I have set for skipping and they keep playing from the begining. Issue is that it felt random - some episodes from the same podcast honored the skipping, some not. I’ll watch it and see if I can find any pattern.