Unable to download some podcasts IO Error: Failed to connect to chtbl.com/

App version:
version 2.1.4 (62b6ec121) from F-Droid

Android version: 5.x (Please mention if you are using a custom rom!)
Android version 10

Device model:

Expected behaviour:
Podcast downloads

Current behaviour:
IO Error: Failed to connect to chtbl.com/

First occurred: (e.g. about x days/weeks ago)
about 6 days ago the error occurred for podcast:
“Money talks with Michael Campbell” CKNW/Curioscast
(a daily podcast. Same issue every day.)

Today the same error is occuring for:
Security Now (Audio) TWiT podcast

Steps to reproduce:

  1. New podcast appears
  2. Then press to download
  3. Then get failed looking in log it says"IO Error: Failed to connect to chtbl.com/
  4. Retried multiple times, same result.

As far as I am aware and can remember I have not changed anything.

This is a known problem of ad blockers like Blockada interfering with the network connection. Just add an exception for AntennaPod :slight_smile:

Thank you. I have not installed any ad blockers, any idea where if there are any ad block settings in the phone itself?

Do you use a VPN? DNS changer? The part is a clear indication that something on your device or on your network connection blocks the download. Maybe try another WiFi network?

Ah, yes. I use a VPN. Now I need to figure out how to add the exception. Thank you for your help.

1 Like

Finally able to get it all working thanks to @ByteHamster
Was not the VPN, but my DNS provider changed or added things that caused the connection to be blocked. It was good to know the info @ByteHamster provided.
Thanks again!

1 Like