Update: tested again today and it's working. Apologies - probably a user error. Please close my ticket. Thank you

Antenna pod version from Google Play:
3.4.0 (5f5d744e7)

Android version 14 from Google Play

Samsung s23 ultra

Expected behaviour: set sleep timer to 60 minutes. Set the “shake to continue” option on. Set the phone down on the wooden border around the bed. Went to bed. Expected to find the podcast stopped at the 60-minute mark, in the morning.

Current behaviour: woke up around 3 hours after going to bed and saw that the podcast was still playing, and about to finish in a few minutes. I mentioned putting the phone on the bed border in case the “shake to continue” was activated by movement in bed however unlikely that seems.

First occurred: Sunday 30 June 2024.

Steps to reproduce:

  1. Set sleep timer to 5 minutes and set the shake option to on.
  2. Put phone down.
  3. Wait 5 minutes.
  4. Check if the podcast stopped playing.

Environment: I do want to set auto download on some podcasts but couldn’t find the option - seemed to be grayed out and set to global option which I also could not finf.
Thanks for your help - I like the look and feel so I’m really hoping to make this my new podcast player after Google continued on their spiral.