Certificate errors when using application

Using antenna 1.8 and 2.0 I am getting certificate errors when adding podcasts and trying to listen. I installed the application from the Google play store.

The device I’m using runs jellybean 4.2.

Is there a solution or workaround for this?

Attached is a picture of the error


This error usually means that the podcast publisher did something wrong on their server. Does this happen with all podcasts or just some? Could you please post the name (or better: url) of the podcasts that this happens with?

It happens with quite a few, here are 2

“Stuff you should know”

The Daily show with Trevor noah: ears edition

Hmm, both of the feeds work on my phone. The hosting company (megaphone) did change their certificate on may 30 (the same date is mentioned in the error message). On your device, AntennaPod still seems to use the old certificate. Have you tried clearing the cache of the AntennaPod app? Be careful to not clear data, though :slight_smile:

Yes it operates on my newer devices. It specifically fails on older versions of Android.

I’ve tried clearing the cache and still has the issue.

I just pasted the URL into a certificate checker. Apparently, one of the root certificates is expired. A (really technical) explanation is available here. The most important part is this:

These roots were added to the following platforms since:

  • Android 5.1 (the other 3 roots)

So the basic problem is indeed that you are using a very old Android version. AntennaPod should already deal with that by using Google Play Services. Now we need to find out why this does not work on your device.

  • Do you use a custom ROM or have rooted your device? (If you do not know what this is, you are probably not using it)
  • (More difficult question) Do you use an updated Google Play Services version? Maybe this can help.

Its using a custom Rom and rooted; it’s a 3rd party device that is built into my car. It’s impossible to do an update on the os version so I am willing to try anything to get it to operate.

Google play services is 20.24.14 (000304-319035315)

Strange. This should theoretically ship modern root certificates.

You can try manually adding the USERTrust RSA Certification Authority to your system. It can be downloaded here but please make sure that you actually trust that certificate. If you download and install a malicious root certificate, the internet connection of the whole device (including app updates etc) will be flawed. The certificate is valid until 2028, so if this works, you should be fine for a while.

That seemed to help with a couple of the podcasts. I only see one other issue, and I think it worked under 1.8.

I’m getting an Ssl error


And I think the last issue is with some of the podcasts that didn’t work because of the root ca being old. Those podcasts can now be added and played, but there is no album art. The art shows up for on my other android devices. Is there something I can do to solve this?

Do you get that error message when downloading or when streaming? Please try downloading if you did not do that before.

There are two separate issues it seems

With the 2 podcasts I had posted above. I thought it was working properly, but I don’t think it is. If I click stream. I get an “error Unable to access media file (1000)”

But if I click download first. Then stream it works. And all the other podcasts episodes in the subscribed feed work too. (Ie I don’t have to hit download first, before I hit stream and it plays)

The issue with the photo above the io error sslv3 one is when I try to add a private stream to my car player. I’m pretty sure it worked in 1.8. And I confirmed I can add this private stream url on different podcast applications on android 4.2. And it certainly works in antenna 2.0 on newer versions of Android.

A bunch of icons and album art doesnt show up in the subscription view.

Thanks, that helps a lot. Now I know what is going on. We have the problem tracked here.

Does the issue also occur when you download something (another podcast’s episode) before trying?

Yes I see the issue when I go into download logs. I get the same error. I added a picture. I also added the photo when I try adding a private feed.

Here is a photo of adding the private feed

I noticed that some of the album art doesnt resize to fit the screen. This is the bottom quarter of the logo

Not sure why it doesn’t size on my display, it resizes on my phone. The resolution of my device is low. Here is the about screen 800x480 pixel. Density 240dpi

Also there are a couple errors in the log

Img cut off

Debug 1


I believe the image being cut off in landscape mode is being tracked here.

1 Like