Notification Media Bar Play Stores Not Work After Inactivity

Environment

Android version: 14
OS version: 5.10.177-android13-4-00003-ga7208022a7ea-ab10815828
AntennaPod version: 3.2.0
Model: Pixel 7
Device: panther
Product: panther

No crash report recorded
App version: x.y.z (state whether from Google Play/F-Droid/Custom built APK)

Google Play 3.2.0 (58081fe5b)

Android version: 5.x (Please mention if you are using a custom rom!)

5.10.177-android13-4-00003-ga7208022a7ea-ab10815828
#1 Fri Sep 15 16:40:54 UTC 2023

Device model:
Pixel 7

Expected behaviour:
When I press play in the notification bar Media control, I expect the podcast to play

Current behaviour:
If time has emailed since I last listened, I haven’t figured out how long yet, then the play button doesn’t work. If I am actively listening then I can pause and play via the notification media control

First occurred: (e.g. about x days/weeks ago)
One week

Steps to reproduce:

  1. Play a podcast
  2. Stop the podcast
  3. Then wait some time, unknown
  4. Try starting the podcast from the media control in notification bar

Environment: (Settings you have changed (e.g. Auto Download). “Unusual” devices you use (e.g. Bluetooth headphones). Did you select another media player?)
No

Stacktrace/Logcat:

[if available]
2 Likes

You say Android 14 then later 5.X. Since you have a Pixel 7 I’m assuming your actual Android version is 14?

Anway, this issue has been reported in previous posts (this specific post is about widget behavior but as noted in the replies for it, further testing has verified it also happens with the media player notification)…

It is not yet resolved.

That information was copied out of the bug report in the app itself. Thanks for letting me know it’s already reported. I did search for this specific problem, however I didn’t realize it was part of a widget problem.

Thanks for the clarification that the info was coming from the ‘Report bug’ function in the app. After a little more research, it looks like what it displays as OS version is the kernel version.

I think this is what i reported earlier today, play pause not working from notification player. It disappearing i think is to do with battery optimization as this happens other other apps too.

I’m on pixel 7a so similar but on graphene os. Are you getting it reverting to the old small button style too?

Maybe this is a debug hint. When I clicked the play icon in the unlocked notification player, antennapod started refreshing podcasts rather than resuming playback. Samsung S20