Google Assistant: Looking for testers

Hi,

is there anyone here who uses Google Assistant? AntennaPod 2.2.0 beta introduces experimental support for Google Assistant and it would be good to get some feedback about how/if it works on real-world device configurations. You can say things like:

Hey Google, open the queue in AntennaPod

or

Hey Google, search for Politics in AntennaPod

It would be great if someone could try it and report back their findings :slight_smile:

2 Likes

I tried both and they work!

The queue opened, and I was able to search for politics in my episodes.

Pixel 5, Australian English user :slightly_smiling_face:

1 Like

Both works well, with searching, I was expecting to search for podcasts instead of episodes

1 Like

Nice, thanks for testing! In German, I can only search. Opening specific screens does not work. Maybe I just don’t know the exact words it wants me to say.

It would also be interesting to hear if it also works for more non-english languages. So if there are more people here who use Assistant, please do test and report back :slight_smile:

Curious also: does Google ‘talk’ back to you with the results? Or do you have to check your screen? And does it support ‘pause/play AntennaPod’?

Would it be possible to specify what you’d want to search for? Like ‘search for podcast xxxx’ or ‘search for xxxx in episodes’

Hello,
tested in Italian and both work. When using these commands, Google says “Opening antennapod” and it open the screen with the results. I’ve also tested searches with one or more words “software” and “software libero” and they worked fine.
I was expecting the search results were from the podcast database (e.g. a “free software” podcast) but it returns the episodes from the already subscribed podcast. Not an issue, just reporting. I’m not an user of any google assistant service, so this behaviour may be exactly what you want.

I’ve tried to open other screens of AntennaPod. I’ve said “open Download in AntennaPod” but it opened a “download” search and not the correct screen.

1 Like

Yeah, that’s what happens for me too. I wonder if there is something wrong in AntennaPod or if the Assistant supports that specific feature only in English. Google’s documentation is not too helpful there. Search is based on the get-thing api and opening specific screens is based on the open-app-feature api. According to the website, both are only available in English, which is wrong apparently.

This works for me. I used beta antennapod and android 10. Is there a way to stop and start podcasts?

AntennaPod follows all the requirements needed to do that. I am not sure if it just doesn’t work in German, if I say the wrong terms, or if it does not work at all. Google lists some example queries here: https://developer.android.com/guide/topics/media-apps/interacting-with-assistant#sample-voice-queries

2 Likes

I’ve installed Antennapod 2.2.1 on my mobile and on my linked Google Nest I’m unable to jup into Antennapod anyhow.

Stupid question: how is the speech intent to make it work ?

Try using Google Assistant directly on your phone. I don’t know how this works with linked devices.

Do you mean the technical details? It uses the get-thing API, which sends an android.intent.action.VIEW intent with the url https://antennapod.org/deeplink/search?query=Test (that page is never actually queried, so it does not need to be a valid website).

Maybe it’s a maybe maximal stupid question (I own this device since 1 day) but what I’ve to say to hear a podcast from my Antennapod.
I say “Hey Google, play podcast” and it plays a randomized podcast from Spotify. My expectation is something different and I guess there must be a linking to Antennapod, but how ?

I don’t use Assistant myself, so I have never seen that screen. My guess would be that Google needs to add you to that list. If you find a way to register an app (via manifest, etc) let me know :slight_smile:

According to this website, the following call should work: The Google Assistant and media apps  |  Android Developers

“Play (podcast) on (app name).”

Can you try if that works for you @hannes_a?

@keunes sorry, it doesn’t work.
This Google Assistant  |  Google Developers is the documentation if someone is interested.
I guess the shortcuts are missing Push dynamic shortcuts to Assistant  |  App Actions  |  Google Developers